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FX0S8700CQ 6-Axis Sensor evaluation board
Integration & Setup Guide

The FXOS8700CQ is a 6-axis sensor combining a 3-axis
accelerometer and a 3-axis magnetometer
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Fig : Image of FXOS8700CQ sensor module
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1.1

1. Overview

The FXOS8700CQ is a 6-axis sensor from NXP combining a 3-axis accelerometer and
3-axis magnetometer. It supports I12C and SPI, but here we use I2C.

General description

FXOS8700CQ is a small, low-power, 3-axis linear accelerometer and 3-axis m
agnetometer combined into a single package. The device features a selectable |
2C or point-to-point SPI serial interface with 14-bit accelerometer and 16-bit m
agnetometer ADC resolution along with smart-embedded functions. F

X0S8700CQ has dynamically selectable acceleration full-scale ranges of +2 g/+4 g
/+8 g and a fixed magnetic measurement range of £+1200 pT. Output data rates (
ODR) from 1.563 Hz to 800 Hz are selectable by the user for each sensor. |
nterleaved magnetic and acceleration data is available at ODR rates of up to 400 H
z. FXOS8700CQ is available in a plastic QFN package, and it is guaranteed to
operate over the extended temperature range of -40 °C to +85 °C.

1.2 Features and benefits

Complete 6-axis, e-compass hardware solution.

1.95Vto 3.6 VVDD supply voltage, 1.62 V to 3.6 V VDDIO voltage.

+2 g/+4 g/+8 g dynamically selectable acceleration full-scale range.

+1200 pT magnetic sensor full-scale range.

Output data rates (ODR) from 1.563 Hz to 800 Hz for each sensor and up to 400 Hz
when operated in hybrid mode with both sensors active.

Low noise: < 126 pg/vHz acceleration noise density at 200-Hz bandwidth, < 100 nT/VHz
magnetic noise density at 100-Hz bandwidth.

14-bit ADC resolution for acceleration measurements.

16-bit ADC resolution for magnetic measurements.

Low power: 240 pA current consumption at 100 Hz and 80 pA at 25 Hz with both
sensors active.

Embedded programmable acceleration event functions.

Freefall and motion detection.

Transient detection.

Vector-magnitude change detection.

Pulse and tap detection (single and double).

Orientation detection (portrait/landscape).

Embedded programmable magnetic event functions.

Threshold detection.

Vector-magnitude change detection.

Autonomous magnetic min/max detection.

Autonomous hard-iron calibration.

Programmable automatic ODR change using auto-wake and return-to-sleep functions
to save power. This function works with both magnetic and acceleration event interrupt
sources.

32-sample FIFO for acceleration data only.
Integrated accelerometer self-test function.
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1.3 Applications

Security: motion detection, door opening, smart home applications, robotics, and
unmanned aerial vehicles (UAVs) with electronic compass (e-compass) function.
Medical applications: patient monitoring, fall detection, and rehabilitation.
E-compass in mobile devices, tablets, and personal navigation devices.

User interface (menu scrolling by orientation change, tap detection for button
replacement).

Orientation detection (portrait/landscape: up/down, left/right, back/front orientation
identification).

Augmented reality (AR), gaming, and real-time activity analysis (pedometry, freefall,
and drop detection for hard disk drives and other devices).

Power management for mobile devices using inertial and magnetic event detection.
Wearable devices: motion detection, activity monitoring, sports monitoring, context
awareness, and shock and vibration monitoring (mechatronic compensation, shipping,
and warranty usage logging).

2. Hardware Requirements

2.1 ESP32 development board
2.2 FX0S8700CQ sensor module

3. Wiring Diagram

3.1 For 12C Communication:-

E)i<r$)587OOCQ Sensor Board ESP32 Pin Description

VDD 3.3V Power supply

GND GND Ground

SDA GPI1021 I°C Data

SCL GP1022 1°C Clock

SAQY VCC Address bit 0

SA1Y VCC Address bit 1

INT1/INT2 OPTIONAL Interrupt Output
Table - 01
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If you want to change the 12C Address, please follow the below Table - 02

SA1 SAOQ
ADDR R5 R4 R2 R1
Ox1F NC C NC C
Ox1D C NC NC C
Ox1E C NC C NC
0x1C NC C C NC
Table - 02

C- Connected, NC- Not Connected

3.2 For SPI Communication:

Please remove all the resistors mentioned below to enable SPI communication properly
NC - R1, R2, R4, R5, R18, R20.

4. Software Requirements

4.1 Arduino IDE
4.2 ESP32 board support installed (via Boards Manager)
4.3 Library: Adafruit FXOS8700

(Install via Library Manager: search “Adafruit FXOS8700")

5. How to Install the Adafruit FXOS8700 Library in Arduino

5.1 Follow these simple steps to install the Adafruit FXOS8700 library in the Arduino IDE:

Step 1: Open the Arduino IDE

e Launch the Arduino software on your computer.

Step 2: Open the Library Manager

e Click on the Tools menu in the top navigation bar.
e Select Manage Libraries... from the dropdown.
You'll see the Library Manager window open (as shown in the image - 01).
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File Edit Sketch Tools Help

i Auto Format Ctrl+T
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Fix Enceding & Reload
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2 £ pual Serial Monitor Ctrl+Shift+hM

3 Serial Plotter Ctrl+Shift+L

: 4 WiFi101 7 WiFiNIMA Firmware Updater

void lof ESP Exception Decoder
£/ puy ESP32 Sketch Data Upload

ESP8266 LittleFS Data Upload

2|1 ESP8266 Sketch Data Upload
Board: "ESP32 Dev Module™ 2
Upload Speed: “321600" >
CPU Frequency: “240MHz (WiFi/BT)" >
Flash Frequency: "S0MHz" >
Flash Mode: "QIO" >
Flash Size: "4MB (32Mb)" >
Partition Scheme: "No OTA (1MB APP/3MB SPIFFS)™ >
Core Debug Level: “None" >
PSRAM: "Disabled” >
Arduine Runs On: "Core 1" >
Events Run On: "Core 1" >
Erase All Flash Before Sketch Upload: "Disabled” >

JTAG Adapter: "Disabled"”
Zigbee Mode: "Disabled”
Port

Get Board Info

Programmer: "Esptool”

Burn Bootloader

Image - 01

Step 3: Search for the FXOS8700 Library
¢ In the Library Manager's search bar (top right), type FXOS8700.
e Wait for the list to populate (see example in the image - 02).

s hare
@ Library Manager 4
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[ Adafruit FX0s8700 ~|

{ by Adafruit
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sansor fusion algorithm can be used on faster boards (Teensy 3.2, Arduino Due. etc) or the simpler Madgwick & Manony filters
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Step 4: Install the Adafruit FXOS8700 Library

¢ Find the Adafruit FXOS8700 library in the search results.
e C(lick the Install button next to it.

Sklch_apr7a

W STUp Ccode hard
g @ Library Manager x
Type Wl ] w | Tope a1 ~ | [FNOS
| Adafruit FX058700 ~
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sanzor fusion algosdthm can be used on faster bosrds (Teensy 3.2, Arduino Due. etc) or the simpler Madgwick & Manany Filbers
can be used, for combining the sensor data into reliable absolute srentation readings.
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~
Cose
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Image - 03

Once installed, the library will be ready to use in your Arduino projects!
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6. Sample Arduino Code

6.1 How to Use Example Code for the Adafruit FXOS8700 in Arduino

After installing the Adafruit FXOS8700 library, follow these steps to load and run the example code:

Step 1: Open the Example Code

* In the Arduino IDE, go to the File menu.

* Hover over Examples in the dropdown.

¢ Scroll through the list and find Adafruit FXOS8700.

* Click on the sensorapi example (as shown in the image - 04).

@ sketch_apr17a | Arduine 1.8.1%

File Edit Sketch Tools Help
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Examples
Close

Save
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CQuit
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Ctrl+P
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Ctrl+Q

&
WiFiProv »
Wire »
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Adafruit FONA Library ’
Adafruit FXOS8700 H sensorapi
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Adafruit SGP40 Sensor *
Adafruit SHT31 Library *
Adafruit 5501306 >
Adafruit Unified Sensor >
Adafruit_VL33L0X ?
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DW1000 ¥
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ESP Async WebServer

ESP AsyncTCP

ESP8266 and ESP32 OLED driver for SSD1308
v

ESP32 Dev Module. Di

Image - 04
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& sensorapi | Arduino 1.2.19
File Edit Sketch Tools Help

sensorapi
| #include <Adafruit FXOS8700.h>

4 Hdaf:uit_E‘XOSBTDD accelmag = Rdafruit_E‘XDSB?DO[CIxB".I‘DD.‘-!., 0xB7008B) ;

5 void displaySensorDetails(void) {
sensor_t accel, mag;
accelmag.getSensor (kaccel, &mag);

Serial.prin
Serial.g
Serial.println
Serial.g t ("Sensor: ™
Serial.g tln{accel.name);
Serial.g t("Driver Ver: L 5]
Serial tln({accal.version);

1& Serial.print ("Unicque ID: DE™).2

1 Serial.println(accel.sensor_id, HEX);

18 Serial.g t("Min Delay: ":
t (accel.min_delay);
Ein(® a%);

t("Max Valus: b [

15 Serial.g
2C Serial.g

Serial.g
nt (accel .max_value, 4);

AnFIn M mioA30y .

Serial.g

Cawvdiaml w

ESF32 Dewv Module. Disabled, Dis|

Image - 05

Note: Depending on your library version, the example name or folder structure may vary slightly.

Step 2: Connect the Hardware

e Plug your ESP32 module into your computer via USB.
e Make sure your FXOS8700CQ sensor is wired to the ESP32 correctly according to the
connection table (you can include or refer to this table here).

Step 3: Select the Correct Port and Board

¢ In the Arduino IDE, go to Tools > Board and select your specific ESP32 board.
e Then go to Tools > Port and choose the correct COM port for your ESP32 (as shown in
the image - 06).
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& sensorapi | Arduino 1.2.19
File Edit Sketch Tools Help
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14 Seri;
Serii
Serii
Seri,
Serij
1E Serij
20 Seri,
Seri|

22 Seri|

Cawmd

Auto Format

Archive Sketch

Fix Enceding & Reload
Manage Libraries..,
Serial Monitor

Serial Plotter
WAFI101 S WAFINIMA Firrnware Updater

ESP Exception Decoder
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Partition Scheme: "No OTA (1MB APP/3MB SPIFFS)”

Core Debug Level: "Mone”
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Arduine Runs On: “Core 1"

Events Run On: "Core 1"

Erase All Flash Before Sketch Upload: "Disabled”
JTAG Adapter: "Disabled”
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Port

Get Beard Info

Programmer. "Esptocl”

Burn Bootloader

Ctrl+T

Ctrl+ Shift+]
Ctrl+Shift+ b
Ctrl+Shift+L

00A, O0x8700B);

32 Dev Module, Disabled, Disabled,|

Step 4: Upload the Code

Image - 06

e Click the Upload button in the Arduino IDE (the right arrow icon).
e Wait for the code to compile and upload to your board.

Step 5: View the Output

o After uploading, open the Serial Monitor from the Tools menu.

e Set the baud rate to match the one used in the example code (usually 9600, but
check the code to confirm).

e You should now see real-time sensor data, including all 6 axes:

1. 3 axes of magnetometer data
2. 3 axes of accelerometer data (See the image - 07 for an example output.)

Page 8



© coms - & X
Send
U ET . APT =F R X U.ZT2F  I: L.023F &: 7.201% W2 |
1:50:47.45% —> M X: 2%.6 ¥: -0.7 3: 31.3 wP
11150147 .49% =>
11:50:47.968 -> A X: 2.165% ¥: -1.8%92 3: 9.2698 mfa"2
11:50:47.968 -> M X: 25.4 Y¥Y: -3.9% Z: 27.8 u¥
11:50:48.014 ->
11:50:48 483 —> A ¥: -3.34%2 v: 0.3829 32: 12.0168 m/3"2
11:50:48.482 => W X: 36.0 ¥r =0.% 31 37T.8 ¥
11:50:48.483 ->
11:50:48.99% > A ¥: -2.6824 ¥: -1.5362 3: 5.3T03 m/fa*2
S50:48.959 =-> H X: 25.8 ¥: 5. Z: 3%.3 aT
11:30:48.955 ->
11150149, 467 => A X1 =2.%71% Y1 =0.T0B3 3r B.7338 mSs*2
11:50:45%.467 -> H X: 25.3 ¥: 5.0 3: 37.1 wT
1:50:49.514 =»
11:50:4%.983 => A X: -4.5440 T: -0.79%44 2Z: B.6333 wfs"2
11:50:49.983 -> M ¥: 28.2 ¥: €.% 32Z: 41.2 T
11:50:50.030 ==>
11:50:50.498 -> A X: -5.0225 ¥: -0.4554 32: §.1117 =fe"2
1:50:50.498 -> M X: 27.0 ¥: 7.1 3Z: 40.5 uT
11:50:50.458 ->
12:%0:5%51.014 —> A X: -5.3%27 vy: -0.%480 32: 7.893% m/3"2
11:50:51.014 28.3 ¥ B.4 31 40.6 uT
11:50:51.014
11:50:51.482 =5.282% ¥: -0.2656 3Z: B.1212 m/fa*2
11:50:51.482 =-> H X: 26.8 ¥: 6. 2: 42.2 aT
11:50:51.52% ->
11:50:51.998 => A X: =5.5035 ¥: =0.1866 3r 7.53%4 m/fa”2
11:50:51.95%8 > H X: 28.9 ¥: 7.9% o: 40.6 T
1:50:51.958 ->
L |
ol dutosoral 2] Show tmestamp BothMLACR | 9600bmxd

Image - 07

7. References

7.1 — FXOS8700CQ Datasheet - NXP

7.2 Adafruit FXOS8700 Library GitHub
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